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Dear Children,

The ICT text book of primary grade must have made studying different

subjects interesting and easy to you. The text book for ICT education in 

Classes  from VI to VIII has been prepared with an objective of helping you 

in studying computer and Internet. This text book will tell you how to make 

tables and charts using spreadsheet, application etc. You will also learn to 

construct a simple web page and the ways to enrich it by adding images and 

pictures. Operating Systems are fundamental to the working of computers. 

This text book  will also helps to understand the basic concepts of computer.

You must take earnest interest in using the computer lab in your school to 

practice the activities given in this text book. I am sure such exercises will 

contribute effectively towards your future learning. 

My special thanks to Miss. A. Hemavathy Ph.d, give an opportunity to share

the computer knowledge to the school students through free software. This 

book is published under Creative Commons.

                                   

Sindhuja Sundaraj
Free Software Hardware Movement

Puducherry
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Basics of Computer

Computer System Definition

Computer System  is  an electronic machine that operates on data accepted by it 
as input, process the data in a predefined way and produces the output known as 
information.

Computer  = Software + Hardware+ User

1.1 Software

Software is set of program  written by programmer that controls the operations of
the computer for computation and processing . Software is divided into three main 
categories. They are
 

 System Software
 Application Software
 Embedded Software

1.1.1 System Software 

System Software comprises of those programs which can interact with the 
hardware.

Eg.  Operating Systems
       Compliers
       Interpreter 
       Languages and Translators.
       Utility Programs.

Operating System

 Operating System is a interface between user and computer I.e  the user can 
communicate with computer by giving commands. These programs are provided by the
manufacturers along with the computing systems, as the instructions sets are different 
for different computer system.

 Eg. MSDOS, UNIX, Linux, Windows etc..



Translators

 Translators is used to converts high level language(i.e english ) to low level 
languages (i.e 0's and 1's). There are three types of translators:

 Compliers
 Interpreter
 Assembler

Application Software

  Application Software includes the computer programs  and related 
documentation that able to solve the real world problems.
 
Eg.  Office Automation
       Animation Software
       Accounting Software

Office Automation

 Office automation is used to solve the real world problems like 
billing,information management,storage and retrieval graphics etc.
 
Eg. Libroffice, Openoffice, My SQL etc..

Animation & Accounting Software

 Animation software is used to create games. Accounting is mainly in stock 
markets and other business purposes.

Eg. GIMP, Blender

Embedded Software

An embedded software is software that has embedded into computer hardware, 
which makes a system dedicated for an application(s) or specific part of an application 
or part of a larger system.

Eg.  Traffic Signals , Railway operations, Banks etc..

Hardware
Hardware is physical components of a computer system. It is something which is

visible and tangible.



Eg. PCB(Printed circuit board)
       Keyboard
       Monitor
      RAM 
       Processor

Components of Computer System

Computer is a device which accept the data,process the data and produce an 
information. The below block diagram shown in the Fig. 1

Fig 1 Architecture of the computer

Central Processing Unit

Input

 The user gives  the data to the computer via keyboard , mouse and scanner.

Processing 

Central Processing Unit is the brain of the computer. The CPU work according to
the instruction given through a software programme. Now-a-days most of the 
components of a computer are incorporated in a Microprocessor  and systems based on 
this chip are termed as Micro Computers. The processor is divided in three parts.

 Arithmetic Logic Unit
 Control Unit
 Memory Unit

Input Output

Memory

Control

ALU



Memory Unit:
        
 It facilitates the remembrance power to computer System.  It refers to the 
physical devices used to store programs or data on a temporary or permanent basis for 
use in a computer or other digital electronic device. Memory can be categorized into 
Volatile and Non-volatile memory.

Volatile Memory(Random Access Memory)

 Volatile memory is a computer memory that requires power to maintain the 
stored information.  Most modem semiconductor volatile memory is either Static RAM
or Dynamic RAM

       Static RAM  retains its contents as long as the power is connected and is easy to 
interface to but uses six transistors per bit.

       Dynamic RAM  is more complicated to interface to and control and needs regular 
refresh cycles to prevent its contents being lost. 

Non-Volatile Memory(Read Only Memory)

 Non-volatile memory is computer memory that can retain the stored information even 
when not powered.
Eg. Flash Memory ,ROM/PROM/EPROM memory (used for firmware such as boot 
programs).

Arithmetic Logic Unit:

 ALU is to perform all the mathematical calculations and logical operations. All 
operations like additions,subtractions,multiplications,divisions and comparisons such 
as less than , equal to, or greater than, etc., are performed in the Arithmetic Logic Unit 
(ALU).

Control Unit:

           The control unit controls the operations of the computer system. It directs the 
flow of information within the computer, e.g. between the memory unit and the ALU, 
or between the Memory  Unit and Devices etc. It also controls the functions of other 
parts of the computer system.



Output

The user gets information from the computer via Printer, Monitor.
Booting

   The process of loading the system files of the operating system from the disk into the 
computer memory to complete the circuitry requirement of the computer system  is 
called booting. There are two types of booting are

     Cold Booting
          If the computer is in off state and we boot the computer by pressing the power 
switch  'ON' from the CPU box then it is called as cold booting.

    Warm Booting
         If the computer is already 'ON' and we restart  it by pressing the RESET button 
from the CPU box or CTRL, ALT and DEL key simultaneously from the keyboard then
it is called warm booting.

Types of Computer

Analog Computer:

     An analog computer  that  is used for  continuous physical phenomena such as 
electrical,mechanical or hydraulic quantities to model the problem being solved.

Eg. Thermometer, Speedometer, Petrol pump Indicator.

Digital Computer

  A computer that performs calculations and logical operations with quantities 
represented as digits, usually in the binary number system.

Hybrid Computer
Hybrid = Analog + Digital
A combination of computers those are capable of inputting and outputting in both

digital and analog signals.  A hybrid computer system setup offers a cost effective 
method of performing complex simulations.  The instruments used im medical science 
lies in this category.

Super Computer
Mainframe Computer
Mini Computer
Micro Computer



Define Microprocessor and Micro controller

Microprocessor

Microprocessor is an IC which has only the CPU inside them i.e only the 
processing powers such as Intel's Pentium 1,2,3,4, core 2 duo,i3,i5 etc.  These 
microprocessors don't have RAM,ROM, and other peripheral on the chip.  A system 
designer has to add them externally to make them functional. Application of 
microprocessor includes Desktop, PC's , Laptops

Micro controller

         Micro controller are designed to perform specific tasks. Specific means 
applications where the relationship of input and output is defined. Depending on the 
input, some processing needs to be done and output is delivered.  For example, 
Keyboards,mouse, digicam etc.. Since the application are very specific they need small 
resources like RAM, ROM, I/O ports etc and hence can be embedded on a single chip.  
This in turn reduces the size and the cost.



Introduction to Free Software

Free Software = Freedom Software 
Free Software not equal to Priceless Software.

Define Free Software?

Free software refers to freedom to use the software without any restrictions. Free 
software is matter of liberity, not about price.  Free software provides four kinds of 
freedom for the users of the software

Freedom 0 : The freedom to run the program, for any purpose

Freedom 1 : The freedom to study how the program works, and adapt it your needs.
(Access the source code)

Freedom 2: The freedom to copy the software and give it your neighbours

Freedom 3:  The freedom to improve the program and release the modified version to 
the public, so that the whole community benefits.

A program is a free software if users have all of these freedom. Thus you should 
be free to redistribute copies, with or without modifications, either gratis or charging a 
fee for distribution to anyone anywhere. Being free to do these things means that you 
do not have to ask or pay for permission.

You should also have the freedom to make changes and use them privately in your won
work or play, without even mentioning that they exist. If you do publish your changes, 
you should not be required to notify anyone in particular way.

Freedom 0:
                                               

   Freedom to run the program for any purpose.



Freedom  1:
 

                                                         
Freedom to the study the program, how the program works,and access the code

Freedom 2:

-

              Freedom  to copy the software and give it your neighbours

Freedom 3:

The freedom to improve the program and release the modified version to the 
public, so that the whole community benefits.



Let's Learn with Fun
Tux Paint

Tux Paint is a drawing tool you can use to create simple or elaborate drawings.
These drawings can be either black-and-white or color, and can be saved as picture
format.

You have drawn pictures on the wall, ground, sand, slate and paper, have n't you?

We can draw beautiful pictures on computers too. Let's  learn about that.  Tux
Paint is a software that helps us to draw pictures on a computer.

How can we open the Tux Paint window?

Applications → Graphics → Tux Paint

 
 

Don't you see a window like the one given here. Now, let's examine Tux Paint window.

Take a look at the facilities in the four major areas mentioned above.

Click on each tool  in the tool  bar using the mouse pointer  and drag it  over to the
drawing area. What are the various lines and figures that appear there? Now, you can
draw your favorite picture. 



Various tools in Tux Paint

Paint 

Paint is the tool used for drawing using brush. When you select this tool, the
option bar displays a number of brushes of different shapes and sizes. You can draw
pictures by selecting a suitable brush.

Colors

Colors  tool  at  the  bottom.  Use  suitable  colors  to  make  your  picture  more
attractive.

Eraser Tool

Buttons are provided in the tool option bar to change the size of the eraser.

Stamp

Stamp tool is used to get many pictures on the right side of the tool option bar
and also maximize and minimize the picture

Text Control 

Text control is used to select the text tool; different types of letters appear in the
tool option bar. Now, select the required alphabet and color from colors and click on
the space to draw pictures.

Lines Tool

 Lines tool is to draw straight lines with different colors and sizes.

Shapes Tool



Shapes tool is used to draw geometrical figures like rectangles, circles etc..

Magic Tool

Magic is used to make magic in paint such as 

Rainbow: to draw pictures using the colors of the rainbow

Flip: to make the picture upside down.

Mirror: to make a mirror image of the picture.

Fill: To fill colors in picture partially or completely.

 Note:Paint, Tux paint, MyPaint, Open office Draw are some of the software that will
help you to draw picture

 

Richard  Matthew  Stallman  is  a  software  freedom  activist  and  computer
programmer. He campaigns for software to be distributed in a manner such that its
users receive the freedoms to use, study, distribute and modify that software. Software
that ensures these freedoms  is termed free software. He is best known for launching
the  GNU  Project,  founding  the  Free  Software  Foundation,  developing  the  GNU
Compiler Collection and GNU Emacs, and writing the GNU General Public License.
He often, known by his initials,RMS 



Office Tools for  Day to Day Manipulations

Writer for Documentation

Writer is the most widely used software. It is an extremely versatile tool – ideal
for  creating  short  documents,  such  as  letters  and  reports,  with  enough  layout  and
graphics  handling capabilities also to make it  suitable for  sophisticated publishing
chores. 

Starting Openoffice Writer

On the taskbar, click or search, Openoffice Writer. The Writer window open with
a blank document.

The top of the window contains Menu bar, Standard toolbar,objects ,3D settings,
Formula bar etc...

 There are many advantages using Writer . The right side of the window is side 
bar. Goto View → Select Side bar. It consists of properties, gallery,Styles and 
Formatting & Navigator.



Create label for your Notebook using Libre office Writer

 Step 1: Application → Libre Office → Libre Office Writer

Step 2: Goto FILE → New or Ctrl +N (Creating a new document)

Step 3: Before start typing save the file using Ctrl+S or File → Save.

Step 4: Type your name , subject, class , school name etc... using keyboard. 

Step 5: Arrange it using alignment tools. Goto Format MENU → ALIGNMENT.  
Choose LEFT,RIGHT , CENTER  & JUSTIFY based on your preferences.

Step 6: Finally, Save the file again using Ctrl+ S or File → Save.

Step 6: Close the window using Alt+ F4 or File → EXIT or Ctrl+Q(Quit)

Government of Puducherry

 Name:___________________________

 Sub:  ___________________________

 Class: __________________________

 School: _________________________

Free Software Hardware Movement

 Name:___________________________

 Qualification:  ___________________________

 Area of Interest: __________________________

 Membership : _________________________



Prepare a permission letter for going to an education tour.

• Take 10 copies of permission letter without retype.
• Change font size,colour,face.
• Change the line space using Line spacing options

Step 1: Open new file and give a file name and save it using Menus or shortcuts

Step 2: Type the letter as same as you are writing in the paper.

Step 3: Select the content using Ctrl +A or Edit → Select All

Step 4: Goto VIEW → Toolbars → Choose Standard bar

Step 5: Change the content face(font name), size and colour.

Step 6:  Change the line space of letter

Step 7: Finally,Save the file using Ctrl+S.

From,
        XXXX
        YYYY

To,
       XXXX
       YYYY

Sub: 

Dear Sir/Madam, 

I kindly request you to give the permission for me to have a study tour on behalf of the 
School. The tour would be conducted for (no. of days taken for tour) starting 
from............................ to .................... As it is the part of educational plan , I hope you 
permit us to have the study tour. 

Thanking You! 
Yours faithfully,

XXXXXXX



Prepare a list of Items in your geometry box and Pencil box.

• Bullets and Numbering
• Change font style using Bold, Italic and Underline

Step 1: Type the list of items under geometry box, select the items and turn on the 
bullets.

Step2 :Type the list of items under pencil box, Select the items and turn on the numbers
or bullets using Format Menu.

Step 3: Goto FORMAT MENU → Choose bullets, numbers or graphics based on your 
wish.

Step 4: Select geometry , pencil box and make it as bold, italic and underline using 
standard toolbar or word shortcuts.

Bold           - Ctrl+B
Italic           -Ctrl+I

Underline   - Ctrl+ U

Step 5: Save the file.

Step 6: Close the Window.

  Geometry Box
•        Ruler
•        Protector
•        2 Set Squares
•        Divider
•        Pencil
•        compass
•        Scale

Pencil Box
   

1. Pencil
2. Scale
3. Sharpener
4. Eraser
5. Pen



Prepare a Time table using Word

Step 1: Open the new file and save it.

Step 2: Type your School Name, Class and section and make it as bold,underline and 
italic.

Step 3: Insert table using Standard toolbar.

                            (or)
Goto → Table → INSERT TABLE or Ctrl+F12

Step 4: Enter table name, rows and columns.

Step 5: Enter the table values and select the table and change the color of the table

Step 6: Finally, save the file.

Example

DAY/
PERIOD

1 2 3 4 5 6 7

MON ENG ENG ENG ENG ENG ENG ENG

TUE TAMIL TAMIL MATHS ENG TAMIL SCI COMP

WED SST SST SST SST ENG COMP SST

THUR SCI COMP SCI COMP SCI SCI SCI

FRI MATHS TAMIL MATHS MATHS MATHS MATHS MATHS

Exam Time Table
DAY/CLASS I II III IV V

09/02/15 ENG ENG ENG ENG ENG

11/02/15 TAMIL TAMIL TAMIL TAMIL TAMIL

13/02/15 EVS EVS EVS EVS EVS

15/02/15 MATHS MATHS MATHS MATHS MATHS

18/02/15 ART ART ART ART ART



Picture Insertion and Alignment

Step 1: Place the insertion pointer wherever we want to insert the picture.

Step 2: Select PICTURE option from insert menu and click CLIPART (or) FROM File 
option is clicked.

Step3 : Keep the cursor at the place where picture is to be insert

Step 4: In from file option, we have to choose the correct path and give correct file 
name and type then click insert.

(or)
Step 5:  Go to the insert menu and select picture option in it. Then select picture from  
clip art  or file.

Step 4: Then choose the path of the picture file and click ok.

Step 5: Now the picture will be insert in your document.

To Align the Picture:

1. To align the pictures, click on LEFT ALIGN (OR) RIGHT ALIGN (OR) 
CENTRE ALIGN icon.

2. To wrap the text, click text wrapping icon in the picture toolbar.
3. From the pop up options, we can bring the picture to left, bottom,top in front and

behind the text.
4. The picture could be inserted by selecting INSERT → OBJECT options.



Design a Advertisement using Writer

Step 1: Select FILE → NEW to create a New document

Step 2: Goto View Menu and click the Drawing

Step 3: In the text box, enter the content of the advertisement

Step 4: On the INSERT MENU, click the picture and select the picture from file or clip 
art

Step 5: On the FORMATTING TOOLBAR, click FONT and make change in font 
type,size, color and style.

Step 6: The selected text is aligned left, right and center using alignment icons.

Hurry! Hurry !! Hurry!!!

The World Largest Book Exhibition 

No Entrance Fee

To be Held at Indra Gandhi Stadium
On 05-05-2015  10-05-2015



Tabulate and Analyze

Libre Office Calc can be used to create business plans, business forms, 
accounting worksheets, and virtuallly any other document that contains calculated 
numbers. Excel can also be used for statistical analysis and for creating graphical 
displays.

Applications of Calc:

     Calc not only helping calculating numerical data but also gives statistical  
information about the analysis, important aspect is the accuracy, and fast calculations 
of the data, which gives the user the time consumption and reduces his workload,

   Electricity Bills
   Telephone Bills
   Invoice Bills
   Marksheet  Preparation

CELL EDITING AND FORMATTING

Step 1: Libre Office Calc → New or Ctrl+ N, to open the new office dialog box, clicks 
the blank workbook.

Step 2: Enter the data in the new blank worksheet.

Step 3: Select a cell before which you want to insert the cells.

Step 4: From the menu bar select INSERT→ CELL and CLICK SHIFT CELLS 
DOWN option to insert a cell in the upper side of the selected one.

Step 5: We can also insert entire row or column by selecting ENTIRE ROW and 
ENTIRE COLUMN.

Step 6: To delete cell, select the cell or cells that has to be deleted, Select EDIT 
DELETE  and click SHIFTCELLS UP ,then click OK.

Step 7: To insert column from the menu bar select INSERT → COLUMN and click on 
it.

Step 8: To insert row, select INSERT → ROW, The row will be inserted before the 
selected row.
Step 9: To delete row or column, select row or column that has to be deleted by 
clicking on the column header or row header from the menu bar click EDIT → 
DELETE.



CELL EDITING:-

INSERTING ROWS AND COLUMNS:-

S.No Name of the 

Student

Age Class

1 Arun 14 XI

2 Arsh 15 XI

3 Ankit 14 XI

4 Babu 15 XI

DELETING ROWS AND COLUMNS:-

S.No Name of the 

Student

Age Class

1 Arun 14 XI

2 Arsh 15 XI

3 Ankit 14 XI

4 Babu 15 XI
BEFORE COPYING:-

S.No Name of the 

Student

Age Age

1 Arun 14 14

2 Arsh 15 15

3 Ankit 14 14

4 Babu 15 15



AFTER COPYING

S.No Name of the 

Student

Age Age Age

1 Arun 14 14 14

2 Arsh 15 15 15

3 Ankit 14 14 14

4 Babu 15 15 15

TEXT WRAPPING:

S.No Name of the 

Student

Age Class ADDRESS

1 Arun 14 XI NO.4 DEEVGI 

NAGAR, 

2 Arsh 15 XI

3 Ankit 14 XI
                 

Aaron Hillel Swartz   was an American computer programmer, entrepreneur, writer, 

political organizer and Internet hacktivist who was involved in the development of the 

web feed format RSS and the markdown publishing format, the organization Creative 

Commons. 

http://en.wikipedia.org/wiki/Hacktivism


Prepare a mark sheet report using Calc

Step 1: FILE → New Libre Office Calc 

Step 2: Enter the information of the marksheet.

Step 3: Leave the column total and average.

Step 4: Goto the total column and enter the formulae 

AUTOSUM :

1. Select the range of cells, which is to headed and pick up the cell where you wish 
to see the answer.

2. Click the auto sum button in standard tool bar. 'The Sum will be displayed in the 
proceeding cells'.

   = Sum(SCNumber: ECNumber)
  SCNumber  - Starting column name & row number
  ECNumber   - Ending column name & row number

Step 5: Find average using average formulae

AVERAGE:

To calculate average value of the list.
 
  = AVERAGE(NUMBER1, NUMBER2.....)

COUNT:

To count the number of cells those contain number

  = COUNT(VALUE1, VALUE2.......)

Step 6: Change the background color of the marksheet and font color and size of the 
heading.

Step 7: Save the file using Ctrl+ S or File → Save

Step 8: Close the window or Alt+F4.



DATA SORTING:

To create  new work sheet using FILE → NEW or by clicking on CTRL+N and enter 

the records.

Select the range of cells, which are to be arranged.

Click SORT ASCENDING ICON in the standard tool bar to arrange the record from 

the lowest to highest order.

Click SORT DESCENDING ICON  in the standard tool bar to arrange the record from 

the highest to lowest order

To sort multiple records at a time click DATA → SORT from the menu box and choose 

either ascending or descending and enter the records.

GOVERMENT HIGHER SECONDARY SCHOOL
MARKSHEET FOR THE CLASS X

S.NO NAME ENGLISH TAMIL MATHS SCIENCE SOCIAL TOTAL AVERAGE COUNT
1 ARAVIND 90 90 90 67 75 412 82.4 8
2 BAB 67 78 89 67 67 368 73.6 8
3 BANU 78 78 78 78 78 390 78 8
4 CHITRA 76 89 90 89 67 411 82.2 8
5 CHINNU 89 78 89 56 89 401 80.2 8
6 DEVI 76 67 89 45 78 355 71 8
7 DIVAKAR 89 67 90 67 56 369 73.8 8
8 FATHIMA 90 89 78 89 76 422 84.4 8
9 GAYATHRI 78 67 67 78 65 355 71 8

10 GOWRI 67 90 90 78 59 384 76.8 8



Prepare a Pay Slip for your company : Calculate grosspay & net pay

Step 1: Open the new file and enter the information

Step 2: Leave the column grosspay and netpay

Step 3: Calculate the grosspay , tax, deduction and netpay

           GROSSPAY = (BASICPAY + DA+TA+HRA)
           TAX = (BASICPAY *10/100)
           NETPAY =(GROSSPAY -(PF+LOAN+TAX))

Step 4:  Save the file using Ctrl+S.

Step 5: Change the background color and font size.

Step 6: Finally,Close the window using Ctrl+Q.

PAYSLIP PREPARATION

NAME BASI
C

PAY

DA HRA TA GROS
S PAY

PF LOAN TAX NET
PAY

ARUN 40000 1500 3000 2000 33500 900 800 4000 27800

AASHA 35000 800 3000 400 30800 900 700 1300 25700

DEVI 35000 800 3000 400 30800 900 700 1300 25700

ROHIT 40000 1500 3000 2000 33500 900 800 4000 27800

ARUN 40000 1500 3000 2000 33500 900 800 4000 27800

KAMAL 35000 800 3000 400 30800 900 700 1300 25700



Prepare an electricity Bill using Libre office Calc

Step 1: Open the New Spreadsheet in Calc.

Step 2: Enter the data such as name, address and number of units.

Step 3: To calculate the changes click insert functions and select it from logical 
category.

Step 4: Enter the condition and rate of charges per units to calculate charges:

TO CALCULATION CHARGES 

UNITS RATE

100-120 UNITS 1 RUPEE P/UNITS

121-150 UNITS 1.20 RUPEES P/UNITS

ABOVE 150 UNITS 2 RUPEES

= IF(E2>200,E2*4, E2*2)



Prepare an invoice bill using libre office calc

Step 1: Open the New Spreadsheet in Calc.

Step 2: Enter the data such as Itemcode, Itemcode and quantity,price and total price.

Step 3: To calculate the total price of the item purchased by the consumer and find the 
maximum and minimum prize of Item.

MAX:
   To find the largest among the set of values
 = MAX(NUMBER1, NUMBER 2)

MIN
  To find the smallest among the set of values
 = MIN(NUMBER 1, NUMBER 2)

VARIANCE:
 To compute the variance of the value in the range
= VAR(NUMBER 1, NUMBER 2)

DATE:
To convert year, month and day parameters into a date

DAY:
 To return the current day of month from date value.

= DAY(SERIAL NUMBER)

Step 4: Enter the condition and rate of charges per units to calculate charges.

Step 5: Close the window or Alt+F4



Present  your Ideas

Libre office Impress

Impress is used to create a successful presentation – slides, handouts, speaker’s 
notes and outlines. It has a set of tools- wizards,templates and auto layouts- which help 
to create presentations quickly and easily.

This software that allows creating a and viewing of slides. A slide can be viewed as 
individual pages of a presentation.

Design Templates and Slide Layout

The main impress windows has three parts: Slides pane, the workspace and the
Task  pane.  Additionally,  several  tool  bars  can  be  displayed  or  hidden  during  the
creation of a presentation.

Slide pane

The Slides pane contains thumbnail pictures of the slides in your presentation.

Add New Slides to the presentation

Mark a slide as hidden so that it will not be longer needed.

Rename a Slide

Duplicate a Slide(Copy and Paste)Slide Transitions and Animation Effects.



Tasks Pane:

The Tasks pane have five sections Properties, Master Pages, Slide transitions, Styles
and formatting, Gallery , Custom Animation and Navigator.

Master Pages – It is used define the page(Slide) style for your presentation. Impress
includes several designs of Master Pages(Slide masters).

Layouts  – It is used page(Slide) view. You can add pictures, videos, graphs and text
based on your wish.

Custom Animation-  A variety  of  animations  can be used to  emphasize  or  enhance
different elements of each slide.

Slide Transition – It provides access to number of slides transition options. The default
is set to No Transitions, in which the following slide simply replaces the existing one.
You can also specify the transition speed.

Gallery – It is used to insert pictures from file or clip art

Workspace:

The workspace (normally in the center)has five tabs: Normal, Outline, Notes, Handout
and slide sorter. 



Create an simple advertisement to convince others to come to your
community. 

Step 1: Start Libre Office Impress, and open a new, blank presentation and save it.

Step 2: Add a new,blank slide. Then, Choose the simple layouts.

Step 3: Enter the title of the presentation.

Step 4: Goto Slide pane and right click get the new slide.

Step 5: Add pictures using Gallery or INSERT à PICTURE

Step 6: Finally, Goto SLIDESHOW MENU à SLIDESHOW or F5.



Create a multimedia time line of important events in your community’s
history.

Step 1 : Open the Impress and choose the layout.

Step 2: Goto Master pages and choose the background templates or color.

Step 3: Add number of slides based on your wish.

Step 4: Insert Pictures and sounds.

Step 5: Give Slide transitions effects to your presentation.

Step 6: Finally play using Slide show or press F5.



Prepare  a  Presentation  about  women  in  the  field  of  technology  with
Statistical report.

Step 1 : Open the Libre office impress and type the information.

Step 2: Add Pictures using Insert Menu.

Step 3: Add the table using table menu and pie chart according to the information.

Step 4: Goto Slide Transitition and animating the slide with effects.

Step 5: Finally Save and present the slide show using F5 .

Step 6: Close the window or Alt + F4.



Create an electronic portfolio that shows the best examples fo the work done by
your Wikimedia Projects.

Step 1: Start Libre Office Impress, and open a new,blank presentation

Step 2: Insert a title slide, and type a title for your portfolio. Then in the box below, 
type the name of the community and other details such as location, year, partners etc…

Step 3: Decide which project awarded by prestigious Institutions, example you want to 
show on the next slide. Then, insert a slide by picking a layout that you think would 
work well for that.

Step 4: Insert the pictures using Gallery from Property Window.

Step 5: Show the stastical picture of the current position of community using 

Insert à Chart and do the report.

Step 6: Choose Slide Transition from Property window.

Step 7: Save using File Menu à Save or Ctrl+S.

Step 8: Repeat the steps 4 through 7 to make three more slides.

Step 9: When you are done adding all of the information in your five slides, pick a 
colour scheme or design template to make your presentation look professional.

Step 10: Set up the slide show to play as whatever type you want, and pick the way you
want to move from one slide to another.

Step 11: Plan your presentation to make sure everything works the way it should make 
any desired changes.

Step 12: Save your work as directed.

Exercise 

1.Prepare a presentation about basics of computer.

2. Prepare a presentation about Sarojini Naidu

3.Prepare a presentation about global warming.



Knowledge through Entertainment 

Stellarium

Stellarium is  a  free  open  source  planetarium for  your  computer.  It  shows  a
realistic sky in 3D, just like what you see with the naked eye,binoculars or a telescope.

 
www.stellarium.org

VLC Player

VLC is a free and open source cross-platform multimedia player and framework that
plays  most  multimedia  files  as  well  as  DVDs,  Audio  CDs,  VCDs,  and  various
streaming protocols.

www.videolan.org 

http://www.videolan.org/
http://www.stellarium.org/


GCompris

Gcompris is high quality educational software suite comprising of numerous activities
such as computer, science, arithmetic, geography, games, reading etc..

www.gcompris.net

Marble

Marble is a virtual globe and world atlas — your swiss army knife for maps. Find your 
way and explore the world!

www.marble.kde.org

http://www.marble.kde.org/
http://www.gcompris.net/


Let's Know Internet

Internet 

Internet is collection of inter connected network through all over the world. The 
word 'Internet' derived from International + Network. 

History of Internet

Internet was developed by ARPA(Advanced Resource Project Agency) in DOD 
(Department of Defence). Initially internet is used for army, later on it comes to 
commercial purpose in year 1980. 

Uses of Internet

    Internet is used to search information globally. The source of information about 
News, sports and entertainment. It is dynamically updating the event within a fraction 
of seconds.

WWW 

World Wide Web  is a way of accessing information over the medium of the 
internet. The Web uses the HTTP protocol, only one of the languages spoken over the 
Internet, to transmit data. It is developed by Tim Berness Lee.

 

Web Browser 

It is an intermediate between user and the internet. The browser shows the 
information from the internet based on user request. 

Ex.

                    Mozilla Firefox,Iseweasel,Google Chrome

                    



Search Engine

                Search Engine is collection of websites in one place. When the user  need 
some information about particular data. It shows websites related to the data.

   Ex.   www.DuckDuckgo.com

            www.wikipedia.com

             www.baidu.com

             www.bing.com

Websites:

     Website is a collection of web pages. It contains several pages related to the 
particular website.

   eg.  Www.tuxpaint.org

          www.stellarium.org

          www.kde.org  etc....

Web pages:

         A Web page ( or webpage ) is a web document that is suitable for the World Wide 
Web and the web browser. It is written in HTML.

HTTP: Hyper Text Transfer Protocol

   In an  internet all the information transfer through HTTP.

Mozilla Firefox:

      Mozilla Firefox is a web browser. It protects and respect the private information.  

IP Address 

 IP (Internet Protocol) is unique numbers for the particular domain 

name IP address is specified in the four hexa decimal values within periods. 

IP comes under two version IPV4 and IPV6. 

eg. 124. 0. 0. 1

E-mail:

 An Electronic mail is the most widely used tool to send messages using 
both computer and communication technology.

http://www.kde.org/
http://www.stellarium.org/
http://Www.tuxpaint.org/
http://www.bing.com/
http://www.yahoo.com/
http://www.wikipedia.com/
http://www.DuckDuckgo.com/


 

http://en.wikipedia.org

www.ta.wikipedia.org

Open street Maps

 It is an collaborative project to create a free editable map of the world.

  
www.openstreetmap.org

http://www.openstreetmap.org/
http://www.ta.wikipedia.org/
http://en.wikipedia.org/


DuckDuckGo
Duckduckgo is  a search engine. What ever information you want it provides the 

website links. It provides real privacy and less clutter.
 

 www.duckduckgo.com

Wikipedia:

Wikipedia is online encyclopedia . It is collaborative project any one can create and modify 

the content. It contains 130 lakh articles in 266 languages. 

http://www.duckduckgo.com/


Let's  we start animate

Draw SWF:

Draw SWF is an animation tool meant to facilitate small movements. This is a simple drawing 

application written in java. It generates animated SWF Files, which redraws everything you have 

drawn with the mouse in the editor. 

www.drawswf.sourceforge.net

Luciole

Luciole is stop motion software for animation movie realization. It can make live capture of 

figures from external devices as webcam or DVD cam. It is distributed under GPL license. 

https://launchpad.net/luciole

https://launchpad.net/luciole
http://www.drawswf.sourceforge.net/
http://www.drawswf.sourceforge.net/


Pencil

Pencil is animation/drawing software. It is used to create traditional hand 

drawn animation (cartoon) using bitmap and vector graphics.

http://www.pencil-animation.org

Tupi 
  It  is (formerly KTooN) is a software application for the design and creation of 
2D Animation.

www.maefloresta.com

http://www.maefloresta.com/
http://www.pencil-animation.org/


Design your web pages

HTML- Hypertext Markup Language is used to create a web pages. Web pages is
collection of text, images and videos, but it transfers in Network using protocols.

HTML consists of elements,attributes and tags. They are two types of tags
  Paired Tags  - Opening and Closing tags are necessary (<html> </html>)
  Singular Tag – empty tags consists of values but there is no closing tag (<img /> <p> 
</br>

 Open Gedit and type the below code and save it as filename.html

Example for Sample Web Page
   <html>                
      <head>   
        <title> My First HTML Page</title>  
       </head>
       <body bgcolor  = “#f1004”>
        My first webpage created by Me
        </body>
     </html>

Header tag -  Head tag consists of title 

Title tag – Title tag consists of title name

Body – Body tag consists of body color and background properties

  <body bgcolor =”#f1093”>  bgcolor is attribute consists of hexa decimal values
  <body background = “picturename.jpg”> background is attribute consists of 
background picture.

<p> - Paragraph tag 
<img>  - Image tag consists of height, width, align, alt , border etc.. These are attributes
to the image.

< img src = “filename.jpg” width =100 height =100 align= “center”>
Font 
 Font tag is used to specify the font color, style, face and size.

   <font color =”red”  face =”times new roman” size =”10”>
   </font>



Marquee 
   
 Marquee tag is used to scrolling across the webpage. Usually, it used to show some 
offers,messages and advertisement.

<marquee bgcolor =”red” direction =”left”> Free Software,Free Scoiety</marquee>

Header
Header tag is used to specify the font size . 

<h1> Font</h1>
     <h2> Font </h2>

  <h3> Font </h3>
<h4> Font </h4>
<h5> Font </h5>
<h6> Font </h6>

HyperLink

   Hyperlink is used to open the new web page. 
 <a href =”link1.html”> Click Here </a>

List
    List is used to listing the items. They are two types of list 
Ordered List
Unordered List

Ordered List: Ordered list is used to list the items in an alphabetical order, roman 
numbers, numerical numbers etc...

    <ol type =”i”>
     <li > Tux Paint</li>
     <li> Open Office </li>
     <li>Gcompris<li>
     </ol>

    <ol type =”a”>
     <li > Tux Paint</li>
     <li> Open Office </li>
     <li>Gcompris<li>
     </ol>



Unordered List
    It is used to specify the infinite number of  things. 

 <ul type =”square”>
 <li> Reading Books </li>
  <li> Watching TV </li>
  <li> Surfing Internet <li>
 </ul>
 <ul type =”Circle”>
 <li> Reading Books </li>
  <li> Watching TV </li>
  <li> Surfing Internet <li>
 </ul>

Design a web page about your personal details.

Step 1: Open Gedit  → Type the code .

Step 2:   Type the code and save it using File → Save or Ctrl +S 

Step 3 : Give an appropriate filename.html

Step 4 : Open the file using Browser (eg.Mozilla Firefox)
 
Step 5 : Goto File → open the file and see your web page. If any mistakes go to your 
html code and change and save it 

Step 6: Goto step 4.

<html>
<head>
<title> Bio data </title>
 <body bgcolor =”lightblue”>
   Name : &nbsp; XXXX
   <br>
   Std : &nbsp: YYY
   <br>
   School: &nbsp :XWW
   <br>
    Area of Interest: &nbsp; XXZZ
    <br>
    Date of Birth : 08/9/1993
    <br>



    Age : 
   <br>
   </body>
 </html>

Design a web page for your School

<html>
 <head
   <title> Government of Puducherry</title>
    <body bgcolor =”lightpink”>
     <center> Government Higher Secondary School </center>
     <br>
     <hr size =”5” noshade><br>
      <marquee bgcolor =”yellow” direction =”left” > Right to Education </marquee>

      <font size =”5” color =”black” face =”times new roman”> As education is the 
basic prerequisite to build a just, equitable, and civil society and a basic tool 
for the development of the individual, the society and the nation, the vision 
of the department is to offer quality education aiming all round development
at all levels in general and to provide 100% access, enrollment, and 
retention at upper primary and secondary levels in particular. <font>
<ul type =”circle”>
 <li> ICT Infrastructure</li>
 <li> Sanitation Facility</li>
  <li> Drinking Water Facility</li>
  <li> Ground </li>
  <li> Teachers Students Ratio </li>
 </ul>
 <img src =”school.jpeg” alt =”school” height =400 width =600>
  <a href =”link1.html”> Click here <a>
  </body>
  </html>





ABBREVATIONS

COMPUTER – Common Operated Machine Particularly Used for Trade & 
Engineering Research

ALU – Arithmetic Logic Unit

CPU  - Central Processing Unit

VDU  - Visual Display Unit

CU  - Control Unit

MOUSE  - Manually Operated User Selection Equipment.

INTERNET – International Network

UPS    - Universal Power Supply

OS -Operating System

VGA – Video Graphics Array

ROM- Read Only Memory

RAM  - Random Access Memory

DVD – Digital Versatile Disk

BIOS  - Basic Input Output System

PPP – Point -to-Point

LAN  -Local Area Network

ISP – Internet Service Provider

IP – Internet Protocol

HTTP  -Hyper Text Markup Language


